The incident has been resolved, and all services are operating normally. We appreciate your patience and understanding while we worked to restore service.
Posted Apr 08, 2026 - 18:12 EDT
Monitoring
A fix has been implemented and we are actively monitoring system performance to ensure the issue is fully resolved and services remain stable.
Posted Apr 08, 2026 - 15:32 EDT
Update
We are continuing to work on a fix for this issue.
Posted Apr 08, 2026 - 13:55 EDT
Identified
The issue has been identified and we are currently working on a resolution. Thank you for your patience as we continue efforts to restore services.
Posted Apr 08, 2026 - 13:06 EDT
Investigating
We are currently investigating slowness with DealCentre. Teams are investigating the issue. We will provide updates as more information becomes available.
Posted Apr 08, 2026 - 12:01 EDT
This incident affected: DealCentre (Americas, EU).