DealCentre Q&A Tab Issue

Incident Report for Intralinks Status Page

Resolved

We have identified the issue and fix will be put in place shortly.
Posted Jun 09, 2026 - 17:34 EDT

Investigating

We are currently investigating an issue where the Q&A tab functionality in DealCentre is slow or not working at all.
Posted Jun 09, 2026 - 17:31 EDT
This incident affected: DealCentre (Americas, EU).