Services are operating normally. Thank you for your patience while we investigated this issue.
Posted Oct 30, 2025 - 14:38 EDT
Update
Our teams continue to investigate the issue impacting OTP notifications for VDRPro. We are actively working to diagnose the problem and implement a solution. We will share further updates as progress is made
Posted Oct 30, 2025 - 13:51 EDT
Investigating
We’re currently investigating a potential issue affecting OTP email delivery with VDRPro. Our teams are working to identify the root cause and will provide updates as soon as more information becomes available. Thank you for your patience.
Posted Oct 30, 2025 - 12:53 EDT
This incident affected: VDR (United Kingdom, North America and the Rest of the World).