InvestorVision File Upload Services are Degraded
Incident Report for Intralinks Status Page
Resolved
This incident has been resolved.
Posted Nov 23, 2022 - 12:50 EST
Investigating
Customers are reporting, file uploads to InvestorVision portal are not completing. We are currently investigating the issue.
Posted Nov 23, 2022 - 10:54 EST
This incident affected: Investorvision (Europe, Middle East and Africa, North America and Rest of the World).