Multiple clients reported missing Deals in Dealcentre

Incident Report for Intralinks Status Page

Resolved

The incident has been fully resolved, and all services are operating normally. We appreciate your patience and understanding while we worked to restore service.
Posted Sep 05, 2025 - 05:40 EDT

Identified

The cause of the issue has been identified, and a fix is actively being deployed. Thank you for your patience as we work to restore services.
Posted Sep 05, 2025 - 05:36 EDT

Investigating

Our team is actively investigating the issue to determine the cause and implement a resolution. We will provide updates as more information becomes available.
Posted Sep 05, 2025 - 04:49 EDT
This incident affected: DealCentre (EU).